Jump to content
JChartFX Community
  • 0

toUppserCase is not a function when using Motifs


I'm having an issue when trying to use Motifs in my charts. When adding in a call to the hook motif (and tested on others too), I'm seeing the following error:

TypeError: c.toUpperCase is not a function (jchartfx.motif.hook.js:21:309)

  • chart https://website/jchartfx/motifs/jchartfx.motif.hook.js:21
  • _Em https://website/js/jchartfx/jchartfx.system.js:4
  • _0_4 https://website/js/jchartfx/jchartfx.coreVector.js:710
  • e https://website/js/jchartfx/jchartfx.coreVector.js:691

I have tried to include jchartfx.motif.js and that doesn't fix it (in fact if I use that file and remove the actual motif, I still get the error), but according to the documentation from the main site it looks like I only need to include the motif.hook file.

Share this post

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now